PFR lab1 – Dynamic routing base on destination prefixes.

Objetivo: Implementar PFRv2 en un escenario y realizar el enrutamiento dinámico basado en los prefijos de las subnets a las cuales está destinado el tráfico.

Topología:

Configs.

PFRMaster:
!
hostname PFRMaster
!
key chain 1
key 1
key-string lennys
key chain 2
key 1
key-string monica
!

pfr master
policy-rules MYMAP
Applies a configuration from a PfR map to a master controller configuration in PfR master controller configuration mode.

      • Reentering this command with a new PfR map name will immediately overwrite the previous configuration. This behavior is designed to allow you to quickly select and switch between predefined PfR maps.

no max-range-utilization
Maximum exit link utilization range threshold over all the border routers. By default, PfR automatically monitors the utilization of external links on a border router every 20 seconds, and the border router reports the utilization to the master controller. If the utilization range between all the exit links exceeds 20 percent, the master controller tries to equalize the traffic load by moving some traffic classes to another exit link. The maximum utilization range is configured as a percentage.
keepalive 10
(Optional) Configures the length of time that an PfR master controller will maintain connectivity with an PfR border router after no keepalive packets have been received.
logging
Enables syslog messages for a master controller or border router process.
!
border 10.2.18.2 key-chain 1
Enters PfR-managed border router configuration mode to establish communication with a border router.

      • An IP address is configured to identify the border router.
      • At least one border router must be specified to create an PfR-managed network. A maximum of ten border routers can be controlled by a single master controller.

interface FastEthernet1/0 external
Configures a border router interface as an PfR-managed external interface.

      • External interfaces are used to forward traffic and for active monitoring.
      • A minimum of two external border router interfaces are required in an PfR-managed network. At least one external interface must be configured on each border router. A maximum of 20 external interfaces can be controlled by single master controller.

max-xmit-utilization absolute 20
Configures the maximum utilization on a single PfR managed exit link.

      • Use the absolute keyword and kbps argument to specify the absolute maximum utilization on a PfR managed exit link in kbps.
      • Use the percentage keyword and value argument to specify percentag utilization of an exit link.

link-group up
The Performance Routing – Link Groups feature introduced the ability to define a group of exit links as a
preferred set of links, or a fallback set of links for Performance Routing (PfR) to use when optimizing traffic
classes specified in a PfR policy.
interface FastEthernet0/0 internal
Configures a border router interface as an PfR controlled internal interface.

      • Internal interfaces are used for passive monitoring only. Internal interfaces do not forward traffic.
      • At least one internal interface must be configured on each border router.

!
border 10.2.18.6 key-chain 2
interface FastEthernet1/0 external
max-xmit-utilization absolute 20
link-group down
interface FastEthernet0/0 internal
!
learn
PfR supports a learn list configuration mode to simplify the learning of traffic classes. Learn lists are a way to categorize learned traffic classes. In each learn list, different criteria including prefixes, application definitions, filters, and aggregation parameters for learning traffic classes can be configured. A traffic class is automatically learned by PfR based on each learn list criteria, and each learn list is configured with a sequence number.
Only one type of traffic-class command can be specified per learn list, and the throughput (PfR) and delay
(PfR) commands are also mutually exclusive within a learn list.
list seq 10 refname Gastronomia
Creates an PfR learn list and enters learn list configuration mode.

      • Use the seq keyword and number argument to specify a sequence number used to determine the order in which learn list criteria is applied.
      • Use the refname keyword and refname argument to specify a reference name for the learn list.

traffic-class prefix-list gastro
count 10 max 20
throughput
list seq 20 refname Transporte
traffic-class prefix-list transp
count 10 max 20
throughput
delay threshold 200
(Optional) Sets the delay threshold as a relative percentage or as an absolute value.

      • The relative keyword is used to configure a relative delay percentage. The relative delay percentage is based on a comparison of short-term and long-term measurements.
      • The threshold keyword is used to configure the absolute maximum delay period in milliseconds.
      • If the configured delay threshold is exceeded, then the prefix is out-of-policy.

unreachable relative 500
(Optional) Sets the maximum number of unreachable hosts.

      • This command is used to specify the relative percentage or the absolute maximum number of unreachable hosts, based on flows per million (fpm), that PfR will permit for a traffic class entry. If the absolute number or relative percentage of unreachable hosts is greater than the user-defined or the default value, PfR determines that the traffic class entry is OOP and searches for an alternate exit link.
      • The relative keyword is used to configure the relative percentage of unreachable hosts. The relative unreachable host percentage is based on a comparison of short-term and long-term measurements.
      • The threshold keyword is used to configure the absolute maximum number of unreachable hosts based on fpm.

loss relative 125
(Optional) Sets the relative or maximum packet loss limit that PfR will permit for a traffic class entry.

      • The relative keyword sets a relative percentage of packet loss based on a comparison of short-term and long-term packet loss percentages.
      • The threshold keyword sets the absolute packet loss based on packets per million.

resolve delay priority 1 variance 10
Sets policy priority or resolves policy conflicts.

      • This command is used to set priority when multiple policies are configured for the same prefix.When this command is configured the policy with the highest priority will be selected to determine the policy decision. Si no lo pongo PFR no reacciona ante con los cambios del delay.

resolve loss priority 2 variance 10
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
!
interface FastEthernet1/0
ip address 10.2.18.1 255.255.255.252
!
interface FastEthernet2/0
ip address 10.2.18.5 255.255.255.252
!
router eigrp 1
network 10.0.0.0
!
ip prefix-list gastro seq 10 permit 10.0.40.0/23 le 24
!
ip prefix-list transp seq 10 permit 10.0.42.0/23 le 24
!
pfr-map MYMAP 10
Enters PfR map configuration mode to configure a PfR map.

      • Only onematch clause can be configured for each PfRmap sequence.

match pfr learn list Gastronomia
Manually configures a learn list (configurada arriba) as match criteria used to create traffic
classes using a PfR map.
set periodic 90
(Optional) Configures PfR to periodically select the best exit link when the periodic
set mode monitor fast
Configures route monitoring on a PfR master controller.
set active-probe jitter 10.0.27.1 target-port 33033
Creates a set clause entry to assign a target prefix for an active probe.

      • Use the probe-type argument to specify one of four probe types: echo, jitter, tcp-conn, or udp-echo.
      • The ip-addressargument to specify the target IP address of a prefix to be monitored using the specified type of probe.
      • The target-port keyword and number argument are used to specify the destination port number for the active probe.
      • The codec keyword and codec-name argument are used only with the jitter probe type. Specifies the codec value used for Mean Opinion Score (MOS) calculation. The codec values must be one of the

following: g711alaw, g711ulaw, or g729a.

      • The example creates a set clause entry to specify the target IP address of a prefix and a specific port number to actively monitor using jitter.

set probe frequency 20
Creates a set clause entry to set the frequency of the PfR active probe.

      • The seconds argument is used to set the time, in seconds, between the active probe monitoring of the specified IP prefixes.

set link-group up fallback down

Specifies a link group for traffic classes defined in a PfR map to create a PfR policy.
!
pfr-map MYMAP 20
match pfr learn list Transporte
set periodic 90
set mode monitor fast
set active-probe jitter 10.0.27.1 target-port 33033
set probe frequency 20
set link-group down fallback up
!
end
!

PFRBorder1
!
hostname PFRBorder1
!
key chain 1
key 1
key-string lennys
!
pfr border
Enters PfR border router configuration mode to configure a router as a border router.

      • The border router must be in the forwarding path and contain at least one external and internal interface.

local FastEthernet0/0
Identifies a local interface on a PfR border router as the source for communication with an PfR master controller.
master 10.2.18.1 key-chain 1
Enters PfR-managed border router configuration mode to establish communication with a master controller.

      • An IP address is used to identify the master controller.
      • The value for the key-chain-name argument must match the key-chain name.

!
interface FastEthernet0/0
ip address 10.2.18.2 255.255.255.252
!
interface FastEthernet1/0
ip address 10.2.18.9 255.255.255.252
!
router eigrp 1
network 10.0.0.0
!
end
!

PFRBorder2:
!
hostname PFRBorder2
!
key chain 1
key 1
key-string monica
!
pfr border
local FastEthernet0/0
master 10.2.18.5 key-chain 1
!
interface FastEthernet0/0
ip address 10.2.18.6 255.255.255.252
!
interface FastEthernet1/0
ip address 10.2.18.13 255.255.255.252
!
router eigrp 1
network 10.0.0.0
!
end
!

Checking.

PFRMaster#sh pfr master
OER state: ENABLED and ACTIVE
Conn Status: SUCCESS, PORT: 3949
Version: 3.3
 Number of Border routers: 2
  Number of Exits: 2
Number of monitored prefixes: 5 (max 5000)
Max prefixes: total 5000 learn 2500
Prefix count: total 5, learn 5, cfg 0
PBR Requirements met
Nbar Status: Inactive
Auto Tunnel Mode: On

Border           Status                UP/DOWN             AuthFail  Version  DOWN Reason
10.2.18.2        ACTIVE                UP       01:47:31          0  3.3
10.2.18.6        ACTIVE                UP       01:45:47          0  3.3

Global Settings:
max-range-utilization percent 0 recv 0
rsvp post-dial-delay 0 signaling-retries 1
mode route metric bgp local-pref 5000
mode route metric static tag 5000
trace probe delay 1000
logging
exit holddown time 60 secs, time remaining 0
Default Policy Settings:
backoff 90 900 90
delay threshold 200
holddown 90
periodic 0
probe frequency 56
number of jitter probe packets 100
  mode route control
  mode monitor both
loss relative 125
jitter threshold 20
mos threshold 3.60 percent 30
unreachable relative 500
trigger-log percentage 30
resolve delay priority 1 variance 10
resolve loss priority 2 variance 10
Learn Settings:
  current state : STARTED
time remaining in current state : 112 seconds
throughput
no delay
no inside bgp
  monitor-period 1
periodic-interval 0
aggregation-type prefix-length 24
prefixes 100 appls 100
expire after time 720
  Learn-List seq 10 refname Gastronomia
Configuration:
Traffic-Class Prefix-list: gastro
Aggregation-type: prefix-length 24
Learn type: throughput
Session count: 10 Max count: 20
Policies assigned: 10
Status: ACTIVE
Stats:
Traffic-Class Count: 2
  Learn-List seq 20 refname Transporte
Configuration:
Traffic-Class Prefix-list: transp
Aggregation-type: prefix-length 24
Learn type: throughput
Session count: 10 Max count: 20
Policies assigned: 20
Status: ACTIVE
Stats:
Traffic-Class Count: 2

PFRMaster#sh pfr master prefix
OER Prefix Statistics:
Pas – Passive, Act – Active, S – Short term, L – Long term, Dly – Delay (ms),
P – Percentage below threshold, Jit – Jitter (ms),
MOS – Mean Opinion Score
Los – Packet Loss (packets-per-million), Un – Unreachable (flows-per-million),
E – Egress, I – Ingress, Bw – Bandwidth (kbps), N – Not applicable
U – unknown, * – uncontrolled, + – control more specific, @ – active probe all
# – Prefix monitor mode is Special, & – Blackholed Prefix
% – Force Next-Hop, ^ – Prefix is denied
Prefix                  State     Time Curr BR         CurrI/F         Protocol
PasSDly  PasLDly   PasSUn   PasLUn  PasSLos  PasLLos
ActSDly  ActLDly   ActSUn   ActLUn      EBw      IBw
ActSJit  ActPMOS  ActSLos  ActLLos
——————————————————————————————-
10.0.40.0/24            INPOLICY       @8 10.2.18.2       Fa1/0           EIGRP
U        U        0        0        0        0
22       22        0        0        1        1
12        0        0        0
10.0.41.0/25            INPOLICY      @28 10.2.18.2       Fa1/0           EIGRP
U        U        0        0        0        0
22       22        0        0        1        1
12        0        0        0
10.0.42.0/26            INPOLICY      @49 10.2.18.6       Fa1/0           EIGRP
U        U        0        0        0        0
23       21        0        0        1        1
12        0        0        0
10.0.43.0/27            INPOLICY       @1 10.2.18.6       Fa1/0           EIGRP
U        U        0        0        0        0
23       21        0        0        1        1
12        0        0        0
10.0.44.0/28            INPOLICY        0 10.2.18.2       Fa1/0           EIGRP
U        U        0        0        0        0
U        U        0        0        1        1
N        N

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s