OSPF Lab 3.

Objetivo: Analizar cómo se “enteran” los routers dentro del área 0 que hubo un cambio en una subnet que se encuentra en otra área, digamos área 1. El escenario es el siguiente:

Configuraciones:

R1
!
hostname R1
!
interface FastEthernet1/0
ip address 172.22.8.1 255.255.255.0
!
router ospf 1
router-id 5.5.5.5
network 0.0.0.0 255.255.255.255 area 0
!

R2
!
hostname R2
!
interface FastEthernet1/0
ip address 172.22.8.2 255.255.255.0
!
interface FastEthernet1/1
ip address 172.22.9.1 255.255.255.0
!
router ospf 1
router-id 4.4.4.4
network 172.22.8.0 0.0.0.255 area 0
network 172.22.9.0 0.0.0.255 area 1
!

R3
!
hostname R3
!
interface FastEthernet1/0
ip address 172.22.9.2 255.255.255.0
!
interface FastEthernet1/1
ip address 172.22.10.1 255.255.255.0
!
router ospf 1
router-id 3.3.3.3
network 0.0.0.0 255.255.255.255 area 1
!

Una vez configurados los routers,el ABR R2 genera dos type3 lsa (summary) para las subnets 172.22.9.0/24 y 172.22.10.0/24 y los anuncia dentro del area 0. Si la subnet 172.22.10.0/24 ()tiene algún problema (r3 fasteth1/1 shutdown), R2 debe de generar los type3 lsa para esa subnet y de alguna manera, debe advertírselo a los routers dentro del area0 para que retiren el lsa de sus bases de datos y por lo tanto la ruta generada para esa subnet.

Según la documentación:

Note also that when a router realizes it needs to flush an LSA from the LSDB for an area, it actually sets the age of the LSA to the MaxAge setting (3600) and refloods the LSA. All the other routers receive the LSA, see the age is already at the maximum, causing those routers to also remove the LSA from their LSDBs.

1ro- R3 shutdown interface fast1/1.
2do- Mensaje generados en el ABR R2

!!
*Dec  5 11:57:40.367: OSPF-1 FLOOD Fa1/1: Received update from 3.3.3.3
*Dec  5 11:57:40.367: OSPF-1 FLOOD Fa1/1: Rcv Update Type 1, LSID 3.3.3.3, Adv rtr 3.3.3.3, age 1, seq 0x80000007
(R3 genera un nuevo type1 lsa con las interfaces que tiene activa, le sube el número de secuencia y lo advierta a R2)
*Dec  5 11:57:40.371: OSPF-1 FLOOD Fa1/1: Add Type 1 LSA ID 3.3.3.3 Adv rtr 3.3.3.3 Seq 80000007 to flood list
*Dec  5 11:57:40.375: OSPF-1 FLOOD Fa1/1: Remove Type 1 LSA ID 3.3.3.3 Adv rtr 3.3.3.3 Seq 80000007 flood list
*Dec  5 11:57:40.375: OSPF-1 FLOOD Fa1/1: Stop flood timer
R2#
*Dec  5 11:57:42.767: OSPF-1 HELLO Fa1/0: Send hello to 224.0.0.5 area 0 from 172.22.8.2
*Dec  5 11:57:42.875: OSPF-1 FLOOD Fa1/1: Sending delayed ACK
*Dec  5 11:57:42.875: OSPF-1 FLOOD Fa1/1: Ack Type 1, LSID 3.3.3.3, Adv rtr 3.3.3.3, age 1, seq 0x80000007
(R2 le envía un ACK a R3 por el  type1 lsa recibido)
R2#
*Dec  5 11:57:45.371: OSPF-1 LSGEN: No change in sum LSA 172.22.9.0, mask 255.255.255.0, type 3, age 674, seq 0080000001 to area 0
(El summary para la subnet 172.22.9.0/24 no sufre ningún cambio)
*Dec  5 11:57:45.375: OSPF-1 LSGEN: Build sum 172.22.10.0, mask 255.255.255.0, type 3, age 3600, seq 0x80000002 to area 0
(El summary para la subnet 172.22.10.0/24 tiene que cambiar, puesto que R3 ya no tiene esa subnet activa, por lo tanto R2 crea un summary con para 172.22.10.0/24 con un age de 3600. Esto se conoce cómo MaxAge y le indica a cualquier router que ese lsa ya no es válido. Además, al crear el summary le pone un número de secuencia superior al que ya tenía)
*Dec  5 11:57:45.379: OSPF-1 LSGEN: MTID      Metric      Origin          Topology Name
*Dec  5 11:57:45.379: OSPF-1 LSGEN: 0         16777215                    Base
*Dec  5 11:57:45.383: OSPF-1 FLOOD Fa1/0: Add Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 to 5.5.5.5 retransmission list
*Dec  5 11:57:45.387: OSPF-1 FLOOD Fa1/0: Add Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 to flood list
(R2 advierte el nuevo summary para todos los routers en el area 0)
R2#
*Dec  5 11:57:45.387: OSPF-1 FLOOD Fa1/0: Flooding update to 224.0.0.5 Area 0
*Dec  5 11:57:45.391: OSPF-1 FLOOD Fa1/0: Send Type 3, LSID 172.22.10.0, Adv rtr 4.4.4.4, age 3600, seq 0x80000002 (0)
*Dec  5 11:57:45.391: OSPF-1 FLOOD Fa1/0: Remove Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 flood list
*Dec  5 11:57:45.395: OSPF-1 FLOOD Fa1/0: Stop flood timer
R2#
*Dec  5 11:57:47.947: OSPF-1 FLOOD Fa1/0: Received ACK from 5.5.5.5
*Dec  5 11:57:47.947: OSPF-1 FLOOD Fa1/0: Rcv Ack Type 3, LSID 172.22.10.0, Adv rtr 4.4.4.4, age 3600, seq 0x80000002
*Dec  5 11:57:47.951: OSPF-1 FLOOD Fa1/0: Remove Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 from 5.5.5.5 retransmission list
(Una vez que recibe el ACK, para el contador de flood, deja de transmitir el nuevo lsa y lo remueve de su base de datos.)

!!

3ro- Mensajes generados en R1

*Dec  5 11:57:46.059: OSPF-1 FLOOD Fa1/0: Received update from 4.4.4.4
*Dec  5 11:57:46.059: OSPF-1 FLOOD Fa1/0: Rcv Update Type 3, LSID 172.22.10.0, Adv rtr 4.4.4.4, age 3600, seq 0x80000002 Mask /24
*Dec  5 11:57:46.063: OSPF-1 FLOOD Fa1/0: Add Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 to flood list
*Dec  5 11:57:46.067: OSPF-1 FLOOD Fa1/0: Remove Type 3 LSA ID 172.22.10.0 Adv rtr 4.4.4.4 Seq 80000002 flood list
*Dec  5 11:57:46.067: OSPF-1 FLOOD Fa1/0: Stop flood timer
R1#
*Dec  5 11:57:48.567: OSPF-1 FLOOD Fa1/0: Sending delayed ACK
*Dec  5 11:57:48.567: OSPF-1 FLOOD Fa1/0: Ack Type 3, LSID 172.22.10.0, Adv rtr 4.4.4.4, age 3600, seq 0x80000002
(Una vez que recibe el nuevo summary con age de 3600, y después de anunciarlo a los demás vecinos dentro del area 0, descarta la subnet)

De esta manera todos lo routers se enteran de la pérdida de la subnet.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s