OSPF Lab 6 – InterArea vs IntraAera.

Objetivo: Analizar el enrutamiento basado en rutas de tipo interarea e intraarea en un escenario dado.

Topology:

B2 tiene su enlace principal por el router WAN1. El CoreX aprende la ruta hacia la LAN de B2 por el router WAN1. Tanto el router WAN1 como WAN2 aprenden la ruta hacia la LAN de B2 como una ruta intra-area.  El router WAN2 también aprende una ruta hacia esa LAN a través del area 0, enseñada por el router WAN1, pero esta ruta, del tipo inter-area, no es la preferida.

Según la reglas de OSPF, los routers prefieren las rutas intra-area a las inter-area.

Esto hace que todo el tráfico destinado a la LAN de B2 que llegue al router WAN2 pase por el enlace secundario de B2. Esto rompe con el esquema pensado de tener en B2 un solo enlace traficando.

Posibles soluciones:
1ro – Bloquear la ruta intra-area para la subnet 130.10.2.0/24 que aprende WAN2 desde la interfaz Fa0/1.
2do – Crear una conexión lógica con tunnel entre WAN1 y WAN2 que esté en el area 2.
3ro – Crear una conexión lógica con subinterfaces (router-on-stick) entre WAN1 y WAN2 que esté en el area 2.
4to – Crear otro proceso ospf en WAN2 que incluya el enlace entre WAN2 y B2, cambiar la distancia administrativa del nuevo proceso a 120 y redistribuir las rutas aprendidas de ambos procesos.
5to – Poner una ruta estática en WAN2 para la LAN de B2 que apunte hacia B1.

Configuración básica:

CoreX:
!
hostname CoreX
!
interface FastEthernet0/0
ip address 130.33.36.1 255.255.255.224
!
interface FastEthernet0/1
ip address 130.33.39.1 255.255.255.128
!
router ospf 1
network 130.33.39.1 0.0.0.0 area 0
network 0.0.0.0 255.255.255.255 area 0
!

WAN1:
!
hostname WAN1
!
interface FastEthernet0/0
ip address 130.33.36.2 255.255.255.224
!
interface FastEthernet0/1
ip address 130.38.2.1 255.255.255.252
!
interface FastEthernet0/2
ip address 130.38.2.5 255.255.255.252
ip ospf cost 300
!
router ospf 1
area 1 stub no-summary
area 2 stub no-summary
network 130.33.36.0 0.0.0.255 area 0
network 130.38.2.1 0.0.0.0 area 1
network 130.38.2.5 0.0.0.0 area 2
!

WAN2:
!
hostname WAN2
!
interface FastEthernet0/0
ip address 130.33.36.3 255.255.255.224
!
interface FastEthernet0/1
ip address 130.38.2.9 255.255.255.252
ip ospf cost 400
!
interface FastEthernet0/2
ip address 130.38.2.13 255.255.255.252
!
router ospf 1
area 2 stub no-summary
area 3 stub no-summary
redistribute ospf 2 subnets
network 130.33.36.0 0.0.0.255 area 0
network 130.38.2.13 0.0.0.0 area 3
!
router ospf 2
area 2 stub no-summary
network 130.38.2.9 0.0.0.0 area 2
distance 120
!
ip prefix-list BLOCK seq 15 permit 130.10.2.0/24
!
route-map BLOCK deny 10
match ip address prefix-list BLOCK
match interface FastEthernet0/1
!
route-map BLOCK permit 20
!

B1:
!
hostname B1
!
interface FastEthernet0/0
ip address 130.38.2.2 255.255.255.252
!
interface FastEthernet0/1
ip address 130.10.1.1 255.255.255.0
!
router ospf 1
area 1 stub no-summary
network 0.0.0.0 255.255.255.255 area 1
!

B2:
!
hostname B2
!
interface FastEthernet0/0
ip address 130.38.2.6 255.255.255.252
ip ospf cost 300
!
interface FastEthernet0/1
ip address 130.38.2.10 255.255.255.252
ip ospf cost 400
!
interface FastEthernet0/2
ip address 130.10.2.1 255.255.255.0
!
router ospf 1
area 2 stub no-summary
network 0.0.0.0 255.255.255.255 area 2
!

B3:
!
hostname B3
!
interface FastEthernet0/0
ip address 130.38.2.14 255.255.255.252
!
interface FastEthernet0/1
ip address 130.10.3.1 255.255.255.0
!
router ospf 1
area 3 stub no-summary
network 0.0.0.0 255.255.255.255 area 3
!

Análisis de las opciones:

1ro – Bloquear la ruta intra-area para la subnet 130.10.2.0/24 que aprende WAN2 desde la interfaz Fa0/1.

La única manera de bloquear una ruta intra-area en OSPF es antes de que se instalada en la tabla de rutas. La idea era bloquear este prefijo cuando tuviera cómo interfaz de salida la Fa0/1 pensando que se instalaría la otra ruta del tipo inter-area anunciada por WAN1.

Configuración adicional:

WAN2
!
router ospf 1
distribute-list route-map BLOCK in
!
ip prefix-list BLOCK seq 15 permit 130.10.2.0/24
!
route-map BLOCK deny 10 (
match ip address prefix-list BLOCK
match interface FastEthernet0/1
/Cuando hay dos match comandos, la lógica que se cumple es la del AND
!
route-map BLOCK permit 20
!

Comprobando:

WAN2#sh ip route

Gateway of last resort is not set
130.10.0.0/24 is subnetted, 2 subnets
O IA     130.10.1.0 [110/30] via 130.33.36.2, 00:00:42, Ethernet0/0
O        130.10.3.0 [110/20] via 130.38.2.14, 00:00:42, Ethernet0/2

Por regla, la decisión de inter-area vs intra-area ocurre antes de poner la ruta en la tabla de rutas. De aquí que aunque bloquee la ruta intra-area hacia la LAN de B2 por la Fa0/1, la ruta inter-area nunca será instalada.

Esta solución no funciona.

2do – Crear una conexión lógica con tunnel entre WAN1 y WAN2 que esté en el area 2.

La idea es crear un tunnel entre WAN1 y WAN2 en el Area 2, de esta manera WAN2 creará un LSA tipo 1 que además de tener un link con un costo de 400, tendrá otro link (el tunnel) con menor costo. De esta manera aprenderá la ruta hacia la LAN de B2 a través de WAN1.

Configuración adicional:

WAN1:
!
interface Tunnel1
ip address 130.38.7.1 255.255.255.252
ip mtu 1476
ip tcp adjust-mss 1420
ip ospf 1 area 2
ip ospf cost 50
keepalive 10 3
cdp enable
tunnel source Ethernet0/0
tunnel destination 130.33.36.3
!

WAN2:
!
interface Tunnel1
ip address 130.38.7.2 255.255.255.252
ip mtu 1476
ip tcp adjust-mss 1420
ip ospf 1 area 2
ip ospf cost 50
keepalive 10 3
cdp enable
tunnel source Ethernet0/0
tunnel destination 130.33.36.2
!

Comprobando:

WAN2#sh ip ospf database router 130.38.2.13

Router Link States (Area 2)
LS age: 753
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 130.38.2.13
Advertising Router: 130.38.2.13
LS Seq Number: 8000000F
Checksum: 0x2A93
Length: 36
Area Border Router
Number of Links: 1

Link connected to: a Transit Network
(Link ID) Designated Router address: 130.38.2.10
(Link Data) Router Interface address: 130.38.2.9
Number of MTID metrics: 0
TOS 0 Metrics: 400

WAN2#sh ip ospf database router 130.38.2.13

Router Link States (Area 2)
LS age: 34
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 130.38.2.13
Advertising Router: 130.38.2.13
LS Seq Number: 80000012
Checksum: 0x5745
Length: 60
Area Border Router
Number of Links: 3

Link connected to: another Router (point-to-point)
(Link ID) Neighboring Router ID: 130.33.36.2
(Link Data) Router Interface address: 130.38.7.2
Number of MTID metrics: 0
TOS 0 Metrics: 50

Link connected to: a Stub Network
(Link ID) Network/subnet number: 130.38.7.0
(Link Data) Network Mask: 255.255.255.252
Number of MTID metrics: 0
TOS 0 Metrics: 50

Link connected to: a Transit Network
(Link ID) Designated Router address: 130.38.2.10
(Link Data) Router Interface address: 130.38.2.9
Number of MTID metrics: 0
TOS 0 Metrics: 400

Como se puede ver, ahora el LSA tipo 1 para tiene 3 links en el area 2, uno de ellos con costo 50 a través de WAN1.

WAN2#sh ip route

130.10.0.0/24 is subnetted, 3 subnets
O IA     130.10.1.0 [110/30] via 130.33.36.2, 00:01:18, Ethernet0/0
O        130.10.2.0 [110/360] via 130.38.7.1, 00:00:33, Tunnel1
O        130.10.3.0 [110/20] via 130.38.2.14, 00:01:18, Ethernet0/2
….

La ruta hacia la LAN de B2 a través de WAN1 es la preferida porque es del tipo intra-area (al igual que la que aprende por la Fa0/1) y porque tiene menor costo.

Esta solución funciona.

Ventaja:
-Es dinámica. Si se cae el enlace de B2-WAN1 cambia la ruta en WAN2. Si se cambian los costos del enlace para invertir el enlace principal se mantiene la solución.

Desventajas:
-Interfaz adicional.
-Al crear un tunnel, el mtu del tráfico que pasa por el se ve afectado, disminuye el mtu, y por lo tanto el mss.

3ro – Crear una conexión lógica con subinterfaces (router-on-stick) entre WAN1 y WAN2 que esté en el area 2.

La idea es crear una conexión entre WAN1 y WAN2 en el area 2 configurando subinterfaces, de esta manera WAN2 creará un LSA tipo 1 que además de tener un link con un costo de 400, tendrá otro link (el tunnel) con menor costo. De esta manera aprenderá la ruta hacia la LAN de B2 a través de WAN1.

Configuración adicional:

WAN1:
!
interface Ethernet0/0.2
encapsulation dot1Q 2
ip address 130.38.7.1 255.255.255.252
ip ospf 1 area 2
!

WAN2:
!
interface Ethernet0/0.2
encapsulation dot1Q 2
ip address 130.38.7.2 255.255.255.252
ip ospf 1 area 2
!

Comprobando:

WAN2#sh ip ospf database router 130.38.2.13
….
Router Link States (Area 2)
LS age: 296
Options: (No TOS-capability, DC)
LS Type: Router Links
Link State ID: 130.38.2.13
Advertising Router: 130.38.2.13
LS Seq Number: 8000001E
Checksum: 0xB57D
Length: 48
Area Border Router
Number of Links: 2

Link connected to: a Transit Network
(Link ID) Designated Router address: 130.38.7.1
(Link Data) Router Interface address: 130.38.7.2
Number of MTID metrics: 0
TOS 0 Metrics: 10

Link connected to: a Transit Network
(Link ID) Designated Router address: 130.38.2.10
(Link Data) Router Interface address: 130.38.2.9
Number of MTID metrics: 0
TOS 0 Metrics: 400
….

Como se puede ver, ahora el LSA tipo 1 para tiene 2 links en el area 2, uno de ellos con costo 10 a través de WAN1.

WAN2#sh ip route

130.10.0.0/24 is subnetted, 3 subnets
O IA     130.10.1.0 [110/30] via 130.33.36.2, 01:08:34, Ethernet0/0
O        130.10.2.0 [110/320] via 130.38.7.1, 00:00:04, Ethernet0/0.2
O        130.10.3.0 [110/20] via 130.38.2.14, 04:15:05, Ethernet0/2
130.33.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        130.33.36.0/27 is directly connected, Ethernet0/0

La ruta hacia la LAN de B2 a través de WAN1 es la preferida porque es del tipo intra-area (al igual que la que aprende por la Fa0/1) y porque tiene menor costo.

Esta solución funciona.

Ventaja:
-Es dinámica. Si se cae el enlace de B2-WAN1 cambia la ruta en WAN2. Si se cambian los costos del enlace para invertir el enlace principal se mantiene la solución.

Desventaja:
-Interfaz adicional.

4to – Crear otro proceso ospf en WAN2 que incluya el enlace entre WAN2 y B2, cambiar la distancia administrativa del nuevo proceso a 120 y redistribuir las rutas aprendidas de ambos procesos.
La idea es que la ruta inter-area, sea preferida a la intra-area. Según las reglas de OSPF, esto no es posible si no es de la siguiente manera:

  1. According to section 11 of RFC 2328

, the order of preference for OSPF routes is:

  • intra-area routes, O
  • interarea routes, O IA
  • external routes type 1, O E1
  • external routes type 2, O E2

This rule of preference cannot be changed. However, it applies only within a single OSPF process. If a router is running more than one OSPF process, route comparison occurs. With route comparison, the metrics and administrative distances (if they have been changed) of the OSPF processes are compared. Route types are disregarded when routes supplied by two different OSPF processes are compared.

Pasted from <http://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/9237-9.html>

Podemos  crear otro proceso ospf en WAN2 que incluya el enlace entre WAN2 y B2, cambiar la distancia administrativa del nuevo proceso a 120 y redistribuir las rutas aprendidas de ambos procesos.

Configuración adicional:

WAN2:
!
router ospf 1
redistribute ospf 2 subnets
!
router ospf 2
area 2 stub no-summary
network 130.38.2.9 0.0.0.0 area 2
distance 120
!

Comprobando:

WAN2#sh ip route

Gateway of last resort is 130.38.2.10 to network 0.0.0.0
O*IA 0.0.0.0/0 [120/701] via 130.38.2.10, 00:04:18, Ethernet0/1
130.10.0.0/24 is subnetted, 3 subnets
O IA     130.10.1.0 [110/30] via 130.33.36.2, 01:22:28, Ethernet0/0
O IA     130.10.2.0 [110/320] via 130.33.36.2, 00:04:18, Ethernet0/0
O        130.10.3.0 [110/20] via 130.38.2.14, 04:28:59, Ethernet0/2

Esta solución funciona.

Ventaja:
-Es dinámica. Si se cae el enlace de B2-WAN1 cambia la ruta en WAN2.

Desventaja:
-Dos procesos OSPF en WAN2.
-Redistribución de rutas.
-Ruta externa en WAN1 si se cae el enlace principal.
– Si se cambian los costos del enlace para invertir el enlace principal no se mantiene la solución y hay que reconfigurar.

5to – Poner una ruta estática en WAN2 para la LAN de B2 que apunte hacia B1.

Configuración adicional:

WAN2:
!
ip route 130.10.2.0 255.255.255.0 130.33.36.2
!

Comprobando:

WAN2#sh ip route

Gateway of last resort is not set
130.10.0.0/24 is subnetted, 3 subnets
O IA     130.10.1.0 [110/30] via 130.33.36.2, 00:02:03, Ethernet0/0
S        130.10.2.0 [1/0] via 130.33.36.2
O        130.10.3.0 [110/20] via 130.38.2.14, 00:02:03, Ethernet0/2
130.33.0.0/16 is variably subnetted, 3 subnets, 3 masks

Esta solución funciona.

Ventaja:
-Poca configuración.

Desventaja:
-Está solución no es dinámica. Si se cae el enlace de B2 con WAN1, la ruta no se quita automáticamente.
-Si se cambia los costos del enlace para invertir el enlace principal, hay que cambiar configuración.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s