Easy Virtual Network lab 1.

Objetivo: probar parte de la configuraciones relacionadas con Easy Virtual Network (EVN).

Topología:

R1 Config:
!
hostname R1
!
/EVN vrf definition, diferente a la definida con el ip vrf.
vrf definition blue
/Assigns an EVN tag value.
 vnet tag 1001
 rd 1:1
 !
/Declares carrying the IPv4 prefixes.
 address-family ipv4
/Este comando permite introducir rutas de la vrf red en la blue. Esto es como inter-vnet routing.
  route-replicate from vrf red unicast all
 exit-address-family
!
vrf definition green
 vnet tag 1003
 rd 3:3
 !
 address-family ipv4
 exit-address-family
!
vrf definition red
 vnet tag 1002
 rd 2:2
 !
 address-family ipv4
 exit-address-family
!
/Aquí se declara el listado de VN que van a ser permitidos en el vnet trunk.
vrf list AllowBR
 member blue
 member red
!
interface Ethernet0/0
/Aquí se declara esta interfaz como vnet trunk y se limita el paso de las VNs solo a la blue y red.
 vnet trunk list AllowBR
 ip address 172.22.8.1 255.255.255.0
/Aquí se declaran atributos específicos para una VN en esta interfaz.
 vnet name blue
  ip ospf cost 40
 !
 vnet name red
  ip ospf cost 50
 !
!
interface Ethernet0/1
/Aquí se declara la pertenencia de la interfaz a una VN. Este comando es el mismo que se utiliza con VRF.
 vrf forwarding blue
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/2
 vrf forwarding red
 ip address 10.1.20.1 255.255.255.0
!
interface Ethernet0/3
 vrf forwarding green
 ip address 10.1.40.1 255.255.255.0
!
/Aquí se declara un proceso ospf para cada VN. Esta declaración de OSPF es igual a la utilizada en caso de VRF.
router ospf 1 vrf blue
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf red
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!         
router ospf 3 vrf green
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
R2 config:
!
hostname R2
!
vrf definition blue
 vnet tag 1001
 rd 1:1
 !
 address-family ipv4
 exit-address-family
!         
vrf definition green
 vnet tag 1003
 rd 3:3
 !
 address-family ipv4
 exit-address-family
!
vrf definition red
 vnet tag 1002
 rd 2:2
 !
 address-family ipv4
/Este comando permite introducir rutas de la vrf red en la blue. Esto es como inter-vnet routing.
  route-replicate from vrf blue unicast all
 exit-address-family
!
interface Loopback0
 vrf forwarding blue
 ip address 145.1.5.1 255.255.255.255
!
interface Ethernet0/0
 vnet trunk
 ip address 172.22.8.2 255.255.255.0
!
interface Ethernet0/1
 vrf forwarding blue
 ip address 145.1.1.1 255.255.255.0
!
interface Ethernet0/2
 vrf forwarding red
 ip address 145.1.20.1 255.255.255.0
!
interface Ethernet0/3
 vrf forwarding green
 ip address 145.1.40.1 255.255.255.0
!
router ospf 1 vrf blue
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf red
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!         
router ospf 3 vrf green
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!

Comprobación:

RA#routing-context vrf blue
RA%blue#sh ip route

Routing Table: blue
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Ethernet0/1
L        10.1.1.1/32 is directly connected, Ethernet0/1
C   +    10.1.20.0/24 is directly connected (red), Ethernet0/2
L        10.1.20.1/32 is directly connected, Ethernet0/2
      145.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
O        145.1.1.0/24 [110/50] via 172.22.8.2, 03:41:13, Ethernet0/0.1001
O        145.1.5.1/32 [110/41] via 172.22.8.2, 03:41:13, Ethernet0/0.1001
O   +    145.1.20.0/24 
           [110/60] via 172.22.8.2 (red), 03:39:03, Ethernet0/0.1002
      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.22.8.0/24 is directly connected, Ethernet0/0.1001
L        172.22.8.1/32 is directly connected, Ethernet0/0.1001

Nota: las rutas con el + son replicadas del proceso de enrutamiento de la VN red. Esto tiene como objetivo introducir enrutamiento entre diferentes VN.

RA%blue#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
145.1.5.1         1   FULL/BDR        00:00:38    172.22.8.2      Ethernet0/0.1001

RA%blue#sh ip ospf interface brief 
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Et0/1        1     0               10.1.1.1/24        10    DR    0/0
Et0/0.1001   1     0               172.22.8.1/24      10    DR    1/1
Posted in EVN

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.