Easy Virtual Network lab 2 – Inter Virtual Network routing.

Objetivo: profundizar sobre el inter Virtual Network (VN) routing y cómo las rutas replicadas pueden ser anunciadas mediante procesos de redistribución para propagarlas dentro de la misma VN o globalmente.

Topología:

Para comprobar, se hará ping desde la PC1 hacia la PC2.

R1 config:
!
hostname R1
!
vrf definition blue
 vnet tag 1001
 rd 1:1
 !
 address-family ipv4
/Adicional a la explicación del lab anterior este route replicate replica de la vrf red (la que busco en específico es la 145.1.20.0/24) la rutas aprendidas por este router.
  route-replicate from vrf red unicast all
 exit-address-family
!
vrf definition red
 vnet tag 1002
 rd 2:2
 !
 address-family ipv4
 exit-address-family
!
interface Ethernet0/0
 vnet trunk
 ip address 172.22.8.1 255.255.255.0
!
interface Ethernet0/1
 vrf forwarding blue
 ip address 10.1.2.1 255.255.255.252
!
interface Ethernet0/2
 vrf forwarding red
 ip address 10.1.20.1 255.255.255.0
!
router ospf 1 vrf blue
 capability vrf-lite
/Una vez replicadas las rutas del VN red, hace falta redistribuirlas dentro del proceso de enrutamiento blue para que las rutas se propagen a través de toda la VN. De esta manera, la pc conectada al router R3 sabrá como llegar a la subnet 145.1.20.2.
 redistribute vrf red ospf 2 subnets
 network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf red
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
R2 config:
!
hostname R2
!
vrf definition blue
 vnet tag 1001
 rd 1:1
 !
 address-family ipv4
 exit-address-family
!
vrf definition red
 vnet tag 1002
 rd 2:2
 !
 address-family ipv4
/Este comando permite replicar las rutas de la VN blue en la red. De esta manera, la PC2 sabrá como llegar a la 10.1.1.2.
  route-replicate from vrf blue unicast all
 exit-address-family
!
interface Loopback0
 vrf forwarding blue
 ip address 145.1.5.1 255.255.255.255
!
interface Ethernet0/0
 vnet trunk
 ip address 172.22.8.2 255.255.255.0
!
interface Ethernet0/1
 vrf forwarding blue
 ip address 145.1.1.1 255.255.255.0
!
interface Ethernet0/2
 vrf forwarding red
 ip address 145.1.20.1 255.255.255.0
!
router ospf 1 vrf blue
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
router ospf 2 vrf red
 capability vrf-lite
 network 0.0.0.0 255.255.255.255 area 0
!
R3 config:
!
hostname RC
!
boot-start-marker
boot-end-marker
!
no aaa new-model
clock timezone PST -8
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip source-route       
!
ip cef
no ip domain lookup
multilink bundle-name authenticated
!
interface Ethernet0/0
 ip address 10.1.2.2 255.255.255.252
!
interface Ethernet0/1
 ip address 10.1.1.1 255.255.255.0
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!

 

Comprobación:

R1#sh ip route vrf blue

Routing Table: blue
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
O        10.1.1.0/24 [110/20] via 10.1.2.2, 00:16:00, Ethernet0/1
C        10.1.2.0/30 is directly connected, Ethernet0/1
L        10.1.2.1/32 is directly connected, Ethernet0/1
C   +    10.1.20.0/24 is directly connected (red), Ethernet0/2
L        10.1.20.1/32 is directly connected, Ethernet0/2
      145.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
O        145.1.1.0/24 [110/20] via 172.22.8.2, 00:16:10, Ethernet0/0.1001
O        145.1.5.1/32 [110/11] via 172.22.8.2, 00:16:10, Ethernet0/0.1001
O   +    145.1.20.0/24 
           [110/20] via 172.22.8.2 (red), 00:16:10, Ethernet0/0.1002
      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.22.8.0/24 is directly connected, Ethernet0/0.1001
…


R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
C        10.1.1.0/24 is directly connected, Ethernet0/1
L        10.1.1.1/32 is directly connected, Ethernet0/1
C        10.1.2.0/30 is directly connected, Ethernet0/0
L        10.1.2.2/32 is directly connected, Ethernet0/0
O E2     10.1.20.0/24 [110/10] via 10.1.2.1, 00:17:09, Ethernet0/0
      145.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
O        145.1.1.0/24 [110/30] via 10.1.2.1, 00:17:09, Ethernet0/0
O        145.1.5.1/32 [110/21] via 10.1.2.1, 00:17:09, Ethernet0/0
O E2     145.1.20.0/24 [110/20] via 10.1.2.1, 00:17:09, Ethernet0/0
      172.22.0.0/24 is subnetted, 1 subnets
O        172.22.8.0 [110/20] via 10.1.2.1, 00:17:09, Ethernet0/0


RB#sh ip route vrf red

Routing Table: red
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O   +    10.1.1.0/24 
           [110/30] via 172.22.8.1 (blue), 00:18:20, Ethernet0/0.1001
O   +    10.1.2.0/30 
           [110/20] via 172.22.8.1 (blue), 00:18:25, Ethernet0/0.1001
O        10.1.20.0/24 [110/20] via 172.22.8.1, 00:18:25, Ethernet0/0.1002
      145.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
C   +    145.1.1.0/24 is directly connected (blue), Ethernet0/1
L        145.1.1.1/32 is directly connected, Ethernet0/1
C   +    145.1.5.1/32 is directly connected (blue), Loopback0
C        145.1.20.0/24 is directly connected, Ethernet0/2
L        145.1.20.1/32 is directly connected, Ethernet0/2
      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.22.8.0/24 is directly connected, Ethernet0/0.1002
L        172.22.8.2/32 is directly connected, Ethernet0/0.1002


PC1b#ping 145.1.20.2 source 10.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 145.1.20.2, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.2 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/36 ms
Posted in EVN

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.