VRF and EIGRP named lab.

Objetivo: probar la nueva configuración de named eigrp y alguno de los parámetros adicionales, incluido vrf con eigrp.

Topología:

R1 config:
!
hostname R1
!
/Declaración de la dos vrf.
ip vrf blue
 rd 1:1
!
ip vrf red
 rd 2:2
!
interface Ethernet0/0.1
 encapsulation dot1Q 1 native
/Comando para asignar la interfaz a una vrf
 ip vrf forwarding blue
 ip address 172.22.1.1 255.255.255.252
!
interface Ethernet0/0.2
 encapsulation dot1Q 2
 ip vrf forwarding red
 ip address 172.22.20.1 255.255.255.252
!
interface Ethernet0/1
 ip vrf forwarding blue
 ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/2
 ip vrf forwarding red
 ip address 10.1.20.1 255.255.255.0    
!
/Declaración del proceso de enrutamiento named eigrp para el blue vrf
router eigrp blue
 !
/Asignación del proceso a la vrf blue y al AS 1
 address-family ipv4 unicast vrf blue autonomous-system 1
  !
  af-interface Ethernet0/1
/Passive interface, bajo el nuevo método.
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0.1
/Cambié alguno de los parámetros eigrp que se aplican por interfaces.
   bandwidth-percent 40
   hello-interval 6
   hold-time 18
  exit-af-interface
  !
  topology base
/El offset no sirvió, aunque lo declaré como dice la docu. A lo mejor es un problema de herramienta de simulación.
   offset-list 50 in 8 
  exit-af-topology
  network 10.0.0.0
  network 172.22.0.0
 exit-address-family
!
/Declaración del proceso de enrutamiento named eigrp para el red vrf
router eigrp red
 !
 address-family ipv4 unicast vrf red autonomous-system 1
  !
  af-interface Ethernet0/2
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0.2
   bandwidth-percent 40
   hello-interval 6
   hold-time 18
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 10.0.0.0
  network 172.22.0.0
 exit-address-family
!
/Access list de base para el offset list
access-list 50 permit 145.1.1.0
!
R2 config:
!
hostname R2
!
ip vrf blue
 rd 1:1
!
ip vrf red
 rd 2:2
!
interface Loopback0
 ip vrf forwarding blue
 ip address 145.1.5.1 255.255.255.255
!
interface Ethernet0/0.1
 encapsulation dot1Q 1 native
 ip vrf forwarding blue
 ip address 172.22.1.2 255.255.255.252
!
interface Ethernet0/0.2
 encapsulation dot1Q 2
 ip vrf forwarding red
 ip address 172.22.20.2 255.255.255.252
!
interface Ethernet0/1
 ip vrf forwarding blue
 ip address 145.1.1.1 255.255.255.0
!         
interface Ethernet0/2
 ip vrf forwarding red
 ip address 145.1.20.1 255.255.255.0
!
router eigrp blue
 !
 address-family ipv4 unicast vrf blue autonomous-system 1
  !
  af-interface Ethernet0/1
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0.1
/Adicional a lo mencionado en la configuración de R1, aquí se realiza una summarización para la red 145 que incluye a las subredes de la interfaz ethernet 0/1 y a la loopback0.
   summary-address 145.1.0.0 255.255.0.0
   bandwidth-percent 40
   hello-interval 6
   hold-time 18
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 145.1.0.0
  network 172.22.0.0
 exit-address-family
!
router eigrp red
 !
 address-family ipv4 unicast vrf red autonomous-system 1
  !
  af-interface Ethernet0/2
   passive-interface
  exit-af-interface
  !
  af-interface Ethernet0/0.2
   bandwidth-percent 40
   hello-interval 6
   hold-time 18
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 145.1.0.0
  network 172.22.0.0
 exit-address-family
!

Comprobando:

RA#sh ip eigrp vrf blue neighbors 
EIGRP-IPv4 VR(blue) Address-Family Neighbors for AS(1)
           VRF(blue)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.22.1.2              Et0/0.1                  14 01:33:03    8   100  0  23

RA#sh ip route vrf blue
...
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.1.0/24 is directly connected, Ethernet0/1
L        10.1.1.1/32 is directly connected, Ethernet0/1
D     145.1.0.0/16 [90/1024640] via 172.22.1.2, 01:29:08, Ethernet0/0.1
      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.22.1.0/30 is directly connected, Ethernet0/0.1
L        172.22.1.1/32 is directly connected, Ethernet0/0.1


RA#sh ip eigrp vrf blue interfaces
EIGRP-IPv4 VR(blue) Address-Family Interfaces for AS(1)
           VRF(blue)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/0.1                  1        0/0       0/0           8       0/3           50           0


RA#sh ip protocols vrf blue
*** IP Routing is NSF aware ***

Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 VR(blue) Address-Family Protocol for AS(1) VRF(blue)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
    Metric rib-scale 128
    Metric version 64bit
    NSF-aware route hold timer is 240
    Router-ID: 172.22.1.1
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
      Total Prefix Count: 3
      Total Redist Count: 0

  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    172.22.0.0
  Passive Interface(s):
    Ethernet0/1
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.22.1.2            90      01:35:19
  Distance: internal 90 external 170

Comprobando la sumarización de R2:

RB#sh ip route vrf blue

Routing Table: blue
      10.0.0.0/24 is subnetted, 1 subnets
D        10.1.1.0 [90/1536000] via 172.22.1.1, 01:41:07, Ethernet0/0.1
      145.1.0.0/16 is variably subnetted, 4 subnets, 3 masks
D        145.1.0.0/16 is a summary, 01:36:36, Null0
C        145.1.1.0/24 is directly connected, Ethernet0/1
L        145.1.1.1/32 is directly connected, Ethernet0/1
C        145.1.5.1/32 is directly connected, Loopback0
      172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.22.1.0/30 is directly connected, Ethernet0/0.1
L        172.22.1.2/32 is directly connected, Ethernet0/0.1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.