FR-ATM interworking issue lab1.

Objetivo: simular el problema existente en redes WAN con interworking frame-relay/atm para cuando la subinterface frame-relay del lado del cliente tiene aplicada QoS y no tiene comunicación con el otro extremo.

Topología:

Frame-relay switch:

ATM switch:

Frrouter:
!
hostname Frrouter
!
ip dhcp pool test
   network 10.1.2.0 255.255.255.0
   default-router 10.1.2.1
   domain-name cisco.com
   dns-server 10.1.2.254
   lease 7
!
no ip domain lookup
!
class-map match-all test
 match access-group 101
class-map match-all test-ch
 match ip dscp af31
!
policy-map output
 class test-ch
    bandwidth 60
 class class-default
    bandwidth 30
policy-map FR-128
 class class-default
    shape average 121600 1216 0
  service-policy output
policy-map input
 class test
  set ip dscp af31
 class class-default
  set ip dscp default
!
interface Serial1/0
 bandwidth 128
 no ip address
 encapsulation frame-relay IETF
 serial restart-delay 0
 clock rate 128000 //QoS que incluye fragmentación a 160 bytes.
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 102
  class MAP-FR-128
!
interface FastEthernet2/0
 ip address 10.1.2.1 255.255.255.0
 duplex auto
 speed auto
 service-policy input input
!
router eigrp 1
 network 10.0.0.0
 no auto-summary
!
map-class frame-relay MAP-FR-128
 frame-relay fragment 160
 frame-relay fair-queue
 service-policy output FR-128
access-list 101 permit icmp any any
!
line con 0
 logging synchronous
InterwRtr:
!
hostname InterwRtr
!
no ip domain lookup
!
interface Serial1/0
 bandwidth 128
 no ip address
 encapsulation frame-relay IETF
 serial restart-delay 0
 clock rate 128000
 frame-relay interface-dlci 101 switched
!
interface ATM2/0
 mtu 1500
 no ip address
 no atm ilmi-keepalive
 pvc 1/100
  encapsulation aal5mux fr-atm-srv
 !
connect frf8 Serial1/0 101 ATM2/0 1/100 service-interworking
!
line con 0
 logging synchronous

Explicación:


ATMRouter:
!
hostname ATMRouter
!
no ip domain lookup
!
interface ATM1/0
 mtu 1500
 no ip address
 no atm ilmi-keepalive
!
interface ATM1/0.1 multipoint
 ip address 10.1.1.2 255.255.255.0
 pvc 2/200
  protocol ip 10.1.1.1 broadcast
  encapsulation aal5snap
!
interface FastEthernet2/0
 ip address 10.1.3.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 network 10.0.0.0
 no auto-summary
!
line con 0
 logging synchronous

Comprobación del interworking:

InterwRtr#sh connection all

ID   Name               Segment 1                      Segment 2                     State
============================================================================================
1    frf8            Se1/0 101              ATM2/0 1/100           UP

-InterwRtr#sh connection id 1

FR/ATM Service Interworking Connection: frf8
  Status    - UP
  Segment 1 - Serial1/0 DLCI 101
  Segment 2 - ATM2/0 VPI 1 VCI 100
Interworking Parameters -
    service translation
    efci-bit 0
    de-bit map-clp
    clp-bit map-de

-InterwRtr#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            0            0            0
  Switched       1            0            0            0
  Unused         0            0            0            0

DLCI = 101, DLCI USAGE = FRF.8, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 259           output pkts 113          in bytes 18108
  out bytes 7657           dropped pkts 0           in pkts dropped 0
  out pkts dropped 0                out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  switched pkts 259
  Detailed packet drop counters:
  no out intf 0            out intf down 0          no out PVC 0
  in PVC down 0            out PVC down 0           pkt too big 0
  shaping Q full 0         pkt above DE 0           policing drop 0

-InterwRtr#sh atm pvc
           VCD /                                        Peak  Avg/Min Burst
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts
2/0        1              1   100  PVC    FRATMSRV UBR  155000                UP

– Comprobación del enlace:

-Frrouter#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.1.1.2                Se1/0.1           12 00:07:44   48   288  0  5

-Frrouter#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 3 subnets
D       10.1.3.0 [90/2172416] via 10.1.1.2, 00:05:14, Serial1/0.1
C       10.1.2.0 is directly connected, FastEthernet2/0
C       10.1.1.0 is directly connected, Serial1/0.1

Comprobación de la incompatibilidad del frf.12 (fragmentación) con el interworking (frf.8)

– Con Qos aplicado:

FRrouter
!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 102
  class MAP-FR-128
!
map-class frame-relay MAP-FR-128
 frame-relay fragment 160 (160 bytes)
 frame-relay fair-queue
 service-policy output FR-128
!

-Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 140
Type escape sequence to abort.
Sending 5, 140-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1

!!!!! (perfecto, ahora a probar con un size mayor de 160, donde se ejecuta la fragmentación)

-Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 300
Type escape sequence to abort.
Sending 5, 300-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
..... (Demostrado!)
Success rate is 0 percent (0/5)

– Sin Qos aplicado:

!
interface Serial1/0.1 point-to-point
 ip address 10.1.1.1 255.255.255.0
 frame-relay interface-dlci 102
!

-Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 140
Type escape sequence to abort.
Sending 5, 140-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/43/56 ms

-Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 300
Type escape sequence to abort.
Sending 5, 300-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!! (sin QoS si funciona el ping!)
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/40/52 ms

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.