FR-ATM interworking issue with solution lab2.

Objetivo: dar una solución al problema existente en redes WAN con interworking frame-relay/atm mencionado en el lab.1.

Topología:

Configuraciones:

Frame-relay1 switch:

Frame-relay2 switch:

ATM switch:

Frrouter Main:
!
hostname FrrouterMain
!
ip dhcp pool test
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
domain-name cisco.com
dns-server 10.1.2.254
lease 7
!
no ip domain lookup
!
class-map match-all test
match access-group 101
class-map match-all test-ch
match ip dscp af31
!
policy-map output
class test-ch
bandwidth 60
class class-default
bandwidth 30
policy-map FR-128
class class-default
shape average 121600 1216 0
service-policy output
policy-map input
class test
set ip dscp af31
class class-default
set ip dscp default
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 128000 //QoS que incluye fragmentación a 160 bytes.
!
interface Serial1/0.1 point-to-point
ip address 10.1.1.1 255.255.255.0
frame-relay interface-dlci 102
class MAP-FR-128
!
interface FastEthernet2/0
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
service-policy input input
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
map-class frame-relay MAP-FR-128
frame-relay fragment 160
frame-relay fair-queue
service-policy output FR-128
access-list 101 permit icmp any any
!
line con 0
logging synchronous

InterwRtr1:
!
hostname InterwRtr1
!
no ip domain lookup
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 128000
frame-relay interface-dlci 101 switched
!
interface ATM2/0
mtu 1500
no ip address
no atm ilmi-keepalive
pvc 1/100
encapsulation aal5mux fr-atm-srv
!
connect frf8 Serial1/0 101 ATM2/0 1/100 service-interworking
!
line con 0
logging synchronous

InterwRtr2:
!
hostname InterwRtr2
!
no ip domain lookup
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 128000
frame-relay interface-dlci 102 switched
!
interface ATM2/0
mtu 1500
no ip address
no atm ilmi-keepalive
pvc 2/200
encapsulation aal5mux fr-atm-srv
!
connect frf8 Serial1/0 102 ATM2/0 2/200 service-interworking
!
line con 0
logging synchronous

Frrouter Branch:
!
hostname FrrouterBranch
!
ip dhcp pool test
network 10.1.3.0 255.255.255.0
default-router 10.1.3.1
domain-name cisco.com
dns-server 10.1.3.254
lease 7
!
no ip domain lookup
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
!
interface Serial1/0.1 point-to-point
ip address 10.1.1.2 255.255.255.0
frame-relay interface-dlci 101
!
interface FastEthernet2/0
ip address 10.1.3.1 255.255.255.0
duplex auto
speed auto
service-policy input input
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
line con 0
logging synchronous

Comprobación del interworking:

-InterwRtr1#sh connection all

ID Name Segment 1 Segment 2 State
============================================================================================
1 frf8 Se1/0 101 ATM2/0 1/100 UP

-InterwRtr1#sh connection id 1

FR/ATM Service Interworking Connection: frf8
Status – UP
Segment 1 – Serial1/0 DLCI 101
Segment 2 – ATM2/0 VPI 1 VCI 100
Interworking Parameters –
service translation
efci-bit 0
de-bit map-clp
clp-bit map-de

-InterwRtr1#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static
Local 0 0 0 0
Switched 1 0 0 0
Unused 0 0 0 0

DLCI = 101, DLCI USAGE = FRF.8, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 65 output pkts 45 in bytes 4396
out bytes 3695 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
switched pkts 65
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 00:14:46, last time pvc status changed 00:10:02

-InterwRtr1#sh atm pvc
VCD / Peak Avg/Min Burst
Interface Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
2/0 1 1 100 PVC FRATMSRV UBR 155000 UP

-InterwRtr2#sh connection all

ID Name Segment 1 Segment 2 State
============================================================================================
2 frf8 Se1/0 102 ATM2/0 2/200 UP

-InterwRtr2#sh connection id 2

FR/ATM Service Interworking Connection: frf8
Status – UP
Segment 1 – Serial1/0 DLCI 102
Segment 2 – ATM2/0 VPI 2 VCI 200
Interworking Parameters –
service translation
efci-bit 0
de-bit map-clp
clp-bit map-de

-InterwRtr2#sh frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

Active Inactive Deleted Static
Local 0 0 0 0
Switched 1 0 0 0
Unused 0 0 0 0

DLCI = 102, DLCI USAGE = FRF.8, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

input pkts 74 output pkts 92 in bytes 6371
out bytes 5864 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 0 out bcast bytes 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
switched pkts 74
Detailed packet drop counters:
no out intf 0 out intf down 0 no out PVC 0
in PVC down 0 out PVC down 0 pkt too big 0
shaping Q full 0 pkt above DE 0 policing drop 0
pvc create time 00:13:46, last time pvc status changed 00:10:41

-InterwRtr2#sh atm pvc
VCD / Peak Avg/Min Burst
Interface Name VPI VCI Type Encaps SC Kbps Kbps Cells Sts
2/0 1 2 200 PVC FRATMSRV UBR 155000 UP

Comprobación del enlace:

-FrrouterBranch#sh ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 10.1.1.1 Se1/0.1 14 00:06:03 68 612 0 3

-FrrouterBranch#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, FastEthernet2/0
D 10.1.2.0 [90/2172416] via 10.1.1.1, 00:06:37, Serial1/0.1
C 10.1.1.0 is directly connected, Serial1/0.1

Comprobación de la incompatibilidad del frf.12 (fragmentación) con el interworking (frf.8)

Con Qos aplicado:

FRrouter
!
interface Serial1/0.1 point-to-point
ip address 10.1.1.1 255.255.255.0
frame-relay interface-dlci 102
class MAP-FR-128
!
map-class frame-relay MAP-FR-128
frame-relay fragment 160 (160 bytes)
frame-relay fair-queue
service-policy output FR-128
!

Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 140
Type escape sequence to abort.
Sending 5, 140-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/72/80 ms

Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 300
Type escape sequence to abort.
Sending 5, 300-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
…..
Success rate is 0 percent (0/5)

Sin Qos aplicado:

!
interface Serial1/0.1 point-to-point
ip address 10.1.1.1 255.255.255.0
frame-relay interface-dlci 102
!

Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 140
Type escape sequence to abort.
Sending 5, 140-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/60/68 ms

Frrouter#ping 10.1.3.1 source fastEthernet 2/0 size 300
Type escape sequence to abort.
Sending 5, 300-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/56/76 ms

Solución: Multilink PPP over FrameRelay.
(puede haber otras variantes, cómo class-based shaping)

Nueva configuración de FrrouterMain:
!
hostname FrrouterMain
!
ip dhcp pool test
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
domain-name cisco.com
dns-server 10.1.2.254
lease 7
!
no ip domain lookup
!
class-map match-all test
match access-group 101
class-map match-all test-ch
match ip dscp af31
!
policy-map output
class test-ch
bandwidth 60
class class-default
bandwidth 30
policy-map input
class test
set ip dscp af31
class class-default
set ip dscp default
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 128000
frame-relay traffic-shaping (tiene que estar habilitado)
!
interface Serial1/0.1 point-to-point
bandwidth 128
frame-relay interface-dlci 102 ppp Virtual-Template60 (enable ppp over frame-relay)
class MAP-FR-128
!
interface FastEthernet2/0
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
service-policy input input
!
interface Virtual-Template60
bandwidth 128
ip address 10.1.1.1 255.255.255.0
load-interval 30
ppp multilink
ppp multilink interleave
ppp multilink fragment delay 10
service-policy output output
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
map-class frame-relay MAP-FR-128 (shaping, que se puede hacer de otra manera)
frame-relay cir 121600
frame-relay bc 1216
frame-relay be 0
frame-relay fair-queue
access-list 101 permit icmp any any
!
line con 0
logging synchronous

Nueva configuración de FrrouterBranch:
!
hostname FrrouterBranch
!
ip dhcp pool test
network 10.1.3.0 255.255.255.0
default-router 10.1.3.1
domain-name cisco.com
dns-server 10.1.3.254
lease 7
!
no ip domain lookup
!
class-map match-all test
match access-group 101
class-map match-all test-ch
match ip dscp af31
!
policy-map output
class test-ch
bandwidth 60
class class-default
bandwidth 30
policy-map input
class test
set ip dscp af31
class class-default
set ip dscp default
!
interface Serial1/0
bandwidth 128
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
clock rate 128000
frame-relay traffic-shaping
!
interface Serial1/0.1 point-to-point
bandwidth 128
frame-relay interface-dlci 101 ppp Virtual-Template60
class MAP-FR-128
!
interface FastEthernet2/0
ip address 10.1.3.1 255.255.255.0
duplex auto
speed auto
!
interface Virtual-Template60
bandwidth 128
ip address 10.1.1.2 255.255.255.0
load-interval 30
ppp multilink
ppp multilink interleave
ppp multilink fragment delay 10
service-policy output output
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
map-class frame-relay MAP-FR-128
frame-relay cir 121600
frame-relay bc 1216
frame-relay be 0
frame-relay fair-queue
access-list 101 permit icmp any any
!
line con 0
logging synchronous

Comprobación:

Two virtual-access interfaces have been cloned. First for the member link:

-FrrouterMain# sh inter virtual-access 2
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
Internet address is 10.1.1.1/24
MTU 1500 bytes, BW 128 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 17/255, rxload 17/255
Encapsulation PPP, LCP Open, multilink Open
Link is a member of Multilink bundle Virtual-Access3
PPPoFR vaccess, cloned from Virtual-Template60
Vaccess status 0x44
Bound to Serial1/0.1 DLCI 102, Cloned from Virtual-Template60, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Last input 00:00:01, output never, output hang never
Last clearing of “show interface” counters 00:33:17
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 9000 bits/sec, 8 packets/sec
30 second output rate 9000 bits/sec, 8 packets/sec
7574 packets input, 1077599 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
7687 packets output, 1080309 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

Second for the MLPPP bundle itself:

-FrrouterMain# sh inter virtual-access 3
Virtual-Access3 is up, line protocol is up
Hardware is Virtual Access interface
Internet address is 10.1.1.1/24
MTU 1500 bytes, BW 128 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 17/255, rxload 17/255
Encapsulation PPP, LCP Open, multilink Open
Open: IPCP
MLP Bundle vaccess, cloned from Virtual-Template60
Vaccess status 0x40, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Last input 00:00:02, output never, output hang never
Last clearing of “show interface” counters 00:25:01
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Class-based queueing
Output queue: 0/1000/0 (size/max total/drops)
30 second input rate 9000 bits/sec, 1 packets/sec
30 second output rate 9000 bits/sec, 1 packets/sec
1096 packets input, 1107051 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1095 packets output, 1183882 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

Verify the CBWFQ policy-map:

-FrrouterMain#sh policy-map inter virtual-access 3
Virtual-Access3

Service-policy output: output

Class-map: test-ch (match-all)
820 packets, 1172600 bytes
30 second offered rate 8000 bps, drop rate 0 bps
Match: ip dscp af31 (26)
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 820/1172600
bandwidth 60 kbps

Class-map: class-default (match-any)
354 packets, 20470 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 354/21826
bandwidth 30 kbps

Check PPP multilink status:

-FrrouterMain#ping 10.1.3.1 source fastEthernet 2/0 size 1500
Type escape sequence to abort.
Sending 5, 1500-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 256/268/288 ms

-FrrouterMain#sh ppp multilink
Virtual-Access3
Bundle name: FrrouterBranch
Remote Endpoint Discriminator: [1] FrrouterBranch
Local Endpoint Discriminator: [1] FrrouterMain
Bundle up for 00:27:57, total bandwidth 128, load 1/255
Receive buffer limit 12192 bytes, frag timeout 1000 ms
Interleaving enabled
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x22D4 received sequence, 0x22D3 sent sequence
Member links: 1 (max not set, min not set)
Vi2, since 00:27:57, 160 weight, 150 frag size (fragment size = delay * (bandwidth/8 – en este caso fs=10ms * 128000/8=160 bytes)
)
No inactive multilink interfaces

Y para comprobar que realmente este realizando la fragmentación (jajaja, el objetivo final del lab) pusimos a traficar icmp en la dos máquinas del lab:

Utilizamos el siguiente comando en el Main router:

(Por lo que queda demostrada la solución!!!)
-FrrouterMain#debug ppp multilink fragments
Multilink fragments debugging is on
FrrouterMain#
*Aug 17 15:51:11.791: Vi2 MLP: I frag 0000240A size 158 encsize 4
*Aug 17 15:51:11.839: Vi2 MLP: I frag 0000240B size 158 encsize 4
*Aug 17 15:51:11.839: Vi2 MLP: I frag 0000240C size 158 encsize 4
*Aug 17 15:51:11.851: Vi2 MLP: I frag 0000240D size 158 encsize 4

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s