PPP over Ethernet Client lab.

Objetivo: realizar un laboratorio relacionado con la conectividad PPP over Ethernet.

Topología:

Configuraciones:

RouterX
!
hostname RouterX
!
username username1 password 0 pwd1
username username2 password 0 pwd2
!
bba-group pppoe bba1
virtual-template 10
!
interface Loopback1
ip address 10.1.60.1 255.255.255.0
!
interface Ethernet1/0
description WAN
no ip address
duplex full
pppoe enable group bba1
!
interface Ethernet1/1
ip address 10.1.50.1 255.255.255.0
!
interface Ethernet1/2
description RealWorld
ip address dhcp
!
interface Virtual-Template10
mtu 1492
ip unnumbered Loopback1
ip flow ingress
peer default ip address pool pool1
ppp authentication pap
!
router eigrp 1
network 10.1.50.0 0.0.0.255
network 10.1.60.0 0.0.0.255
!
ip local pool pool1 10.1.60.2 10.1.60.10
!
ip flow-export version 5
ip flow-export destination 172.22.30.245 9999
!
ip route 172.16.0.0 255.240.0.0 172.22.8.200
!
snmp-server community ketshup RO
!

RouterY
!
hostname RouterY
!
interface Ethernet1/0
no ip address
duplex full
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet1/1
ip address 10.1.51.1 255.255.255.0
duplex full
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp pap sent-username username1 password 0 pwd1
!
router eigrp 1
network 10.1.51.0 0.0.0.255
network 10.1.60.0 0.0.0.255

RouterZ
!
hostname RouterZ
!
interface Ethernet1/0
no ip address
duplex full
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Ethernet1/1
ip address 10.1.52.1 255.255.255.0
duplex full
!
interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 1
ppp pap sent-username username2 password 0 pwd2
!
router eigrp 1
network 10.1.52.0 0.0.0.255
network 10.1.60.0 0.0.0.255
!

PC1
Ip: 10.1.50.2/24
Gw: 10.1.50.1

PC2
Ip: 10.1.51.2/24
Gw: 10.1.51.1

PC3
Ip: 10.1.52.2/24
Gw: 10.1.52.1

Comprobación:

RouterX#sh inter des
Interface Status Protocol Description
Fa0/0 admin down down
Et1/0 up up WAN
Et1/1 up up
Et1/2 up up RealWorld
Et1/3 admin down down
Et1/4 admin down down
Et1/5 admin down down
Et1/6 admin down down
Et1/7 admin down down
Lo1 up up
Vi1 down down
Vi2 up up
Vi2.1 up up
Vi2.2 up up
Vt10 down down

RouterX#sh inter virtual-access 2
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1492 bytes, BW 100000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed
Base PPPoE vaccess
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Last input 00:00:00, output never, output hang never
Last clearing of “show interface” counters 02:19:53
Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
7689 packets input, 5917246 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
10985 packets output, 5956687 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

RouterX#sh inter virtual-access 2.1
Virtual-Access2.1 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Loopback1 (10.1.60.1)
MTU 1492 bytes, BW 100000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP
PPPoE vaccess, cloned from Virtual-Template10
Vaccess status 0x0
Keepalive set (10 sec)
1031 packets input, 45055 bytes
1205 packets output, 47531 bytes
Last clearing of “show interface” counters never

RouterX#sh inter virtual-access 2.2
Virtual-Access2.2 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Loopback1 (10.1.60.1)
MTU 1492 bytes, BW 100000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: IPCP
PPPoE vaccess, cloned from Virtual-Template10
Vaccess status 0x0
Keepalive set (10 sec)
632 packets input, 27593 bytes
745 packets output, 29167 bytes
Last clearing of “show interface” counters never

RouterX#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 10.1.60.8 Vi2.2 11 00:30:14 240 1440 0 22
0 10.1.60.6 Vi2.1 11 00:48:11 192 1152 0 25

Real bandwidth?
Podemos utilizar un rate-limit.

RouterY#sh inter des
Interface Status Protocol Description
Fa0/0 admin down down
Et1/0 up up
Et1/1 up up
Et1/2 admin down down
Et1/3 admin down down
Et1/4 admin down down
Et1/5 admin down down
Et1/6 admin down down
Et1/7 admin down down
Di1 up up
Vi1 up up
Vi2 up up

RouterY#sh interfaces virtual-access 1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1492 bytes, BW 100000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed
Base PPPoE vaccess
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
Last input never, output never, output hang never
Last clearing of “show interface” counters 02:39:51
Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

RouterY#sh interfaces dialer 1
Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Internet address is 10.1.60.6/32
MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Interface is bound to Vi2
Last input never, output never, output hang never
Last clearing of “show interface” counters 02:40:25
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4055 packets input, 2932824 bytes
5901 packets output, 2987560 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Stopped: CDPCP
Open: IPCP
PPPoE vaccess, cloned from Dialer1
Vaccess status 0x44, loopback not set
Keepalive set (10 sec)
Interface is bound to Di1 (Encapsulation PPP)
Last input 00:00:01, output never, output hang never
Last clearing of “show interface” counters 00:54:35
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1382 packets input, 54627 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
1382 packets output, 65215 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions

Ok!

Aquí se puede quitar la virtual-template sin afectar las virtual-access, o al menos no da error.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s