L2TPv3 labs, part 1.

Objetivo: realizar configuraciones de L2TPv3 con la creación dinámica de sesiones.

Lab1: L2tpv3 with dynamic session creation.

Topología:

R1 config:
!
hostname R1
!
interface FastEthernet1/0
 ip address 172.16.1.100 255.255.255.0
!
router eigrp 1
 network 172.16.0.0
!
PE left config:
!
hostname R2
!
l2tp-class lennys
 hidden
 authentication
 digest secret 0 carlos
 hello 65
 hostname R2
 password lennys
 receive-window 35
 retransmit retries 10
 timeout setup 400
!
pseudowire-class test
 encapsulation l2tpv3
 sequencing both
 protocol l2tpv3 lennys
 ip local interface Loopback0
 ip pmtu
 ip dfbit set
 ip ttl 100
!
interface Loopback0
 ip address 192.51.101.1 255.255.255.255
!
interface FastEthernet1/0
 description LAN
 no ip address
 xconnect 203.0.114.1 1 pw-class test
!
interface FastEthernet1/1
 description WAN
 ip address 192.51.100.100 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.51.100.1
!
SPNetwork config:
!
hostname SPnetwork
!
interface FastEthernet0/0
 ip address 192.51.100.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 203.0.113.1 255.255.255.0
!
ip route 192.51.101.1 255.255.255.255 192.51.100.100
ip route 203.0.114.1 255.255.255.255 203.0.113.102
!
PE rigth config:
!
hostname R4
!
l2tp-class lennys
 hidden
 authentication
 digest secret 0 carlos
 hello 65
 hostname R4
 password lennys
 receive-window 35
 retransmit retries 10
 timeout setup 400
!
pseudowire-class test
 encapsulation l2tpv3
 sequencing both
 protocol l2tpv3 lennys
 ip local interface Loopback0
 ip pmtu
 ip dfbit set
 ip ttl 100
!
interface Loopback0
 ip address 203.0.114.1 255.255.255.255
!
interface FastEthernet1/0
 description WAN
 ip address 203.0.113.102 255.255.255.0
!
interface FastEthernet1/1
 no ip address
 xconnect 192.51.101.1 1 pw-class test
!
ip route 0.0.0.0 0.0.0.0 203.0.113.1
!
R2 config:
!
hostname R5
!
interface FastEthernet1/0
 ip address 172.16.1.201 255.255.255.0
!
router eigrp 1
 network 172.16.0.0
!

Comprobación:

PE left#sh l2tun tunnel all

L2TP Tunnel Information Total tunnels 1 sessions 1

Tunnel id 1763964805 is up, remote id is 89490355, 1 active sessions
  Locally initiated tunnel
  Tunnel state is established, time since change 00:51:00
  Tunnel transport is IP  (115)
  Remote tunnel name is R4
    Internet Address 203.0.114.1, port 0
  Local tunnel name is R2
    Internet Address 192.51.101.1, port 0
  L2TP class for tunnel is lennys
  Counters, taking last clear into account:
    1620 packets sent, 1615 received
    156975 bytes sent, 156340 received
    Last clearing of counters never
  Counters, ignoring last clear:
    1620 packets sent, 1615 received
    156975 bytes sent, 156340 received
  Control Ns 35, Nr 20
  Local RWS 35, Remote RWS 35
  Control channel Congestion Control is disabled
  Tunnel PMTU checking enabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 2
  Total resends 2, ZLB ACKs sent 19
  Total out-of-order dropped pkts 0
  Total out-of-order reorder pkts 0
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 1 1 0 0 0 0 0 0
  Control message authentication is enabled with 1 digest secrets
  Last control message authenticated with first digest secret

R1#ping 172.16.1.201
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.201, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/101/108 ms

R1#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.16.1.201            Fa1/0                    14 00:48:45  104   624  0  1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.